RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: ECU main relay?


Guru

Status: Offline
Posts: 1211
Date:
RE: ECU main relay?
Permalink  
 


Yes it has an immobiliser, the ECU, immo and keys all need to match. PM me if you need a repair or the new ECU matching to the immo and keys.

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Newbie

Status: Offline
Posts: 4
Date:
Permalink  
 

Thank you for confirmation its the ECU fault, before I open it to see if its repairable I got another ECU withe the same part/model but when I fired it it triggered the relay OK but it shows check engine but won't start. The ECU came from vitara JX the same as mine. On reading the error code it comes up with error code 81, can anyone tell me what this fault is ?

 

 Found that the code 81 is immobiliser codes not matched (ECU side), I did not think my 1998 Vitara 1600 8V had an immobiliser, can I copy all the code from my original ECU to the new one from breakers

Thanks Raymond



-- Edited by RadioRay on Wednesday 18th of February 2015 11:36:23 PM

__________________


Guru

Status: Offline
Posts: 1211
Date:
Permalink  
 

The negative side of the coil is switched by the ECU, if the relay coil went short circuit then it will, almost certainly, have blown the circuit in the ECU.

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Newbie

Status: Offline
Posts: 4
Date:
Permalink  
 

This is for the experts hear.

 

I have a electrical fault with my 1998 vitara 1600 8 valve, ignition on, check engine light out, engine cranked, but would not start.  Fault traced to a failed relay, shorted coil, located next ECU in green socket. Replaced the relay management light was still out and still would not start.

 

On checking the relay +12v on one side of coil but no negative/ground on the negative side of the coil (coil not being triggered) however when I connect the negative side to ground the and energise the relay the management light comes on and I can start the car. Question is the coil trigger negative side of the coil provided by the ecu or some other circuit.

 

I can rig up a temporary fix but need to find a permanent safe solution.

 

Sorry if this has been answered else where but i didn't find it.

 

ECU 33920-70E10



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard