RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: jimny engine light problem


Guru

Status: Offline
Posts: 1274
Date:
RE: jimny engine light problem
Permalink  
 


Australia went to EOBD in 2006 - my memory obviously isn't what it was, I read that on my own page!

http://www.rhinopower.org/diag/diag_main.html



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Guru

Status: Offline
Posts: 1274
Date:
Permalink  
 

I saw that post, I'm watching with interest. The Suzuki dealer tools all use OBD1 so I can't tell from those if there is an OBD2 link but the information that I had was that all 2007 E24 models were OBD1 only.

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Newbie

Status: Offline
Posts: 2
Date:
Permalink  
 

thanks heaps mate hey i asked on auszookers and there was guy told me that he has one and obd2 works with his jimny

i bought a cheap obd2 reader i will find out when it arrives and let u know thanks



__________________


Guru

Status: Offline
Posts: 1274
Date:
Permalink  
 

The 2007 Aus models are not OBD2, they use a different version of the KWP2000 protocol. I don't currently have a tool that will interface to this ECU. Have you tried reading the fault codes using a jumper in the monitor coupler. On the 2007 model I think the connector is behind the glovebox, its worth posting on auszookers.com or bigjinmny.com as someone there will know for sure.

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Newbie

Status: Offline
Posts: 2
Date:
Permalink  
 



hi there my name is tristan slight i live in western australia, australia
i have a 2007 Suzuki jimny m13a vvt which i currently converted to a m18a
engine everything went fine and ran well it has since done about 2000km.
Today the engine light come on but still runs fine the only thing i have
noticed is that the engine at idle is rough and sounds like it is going to
cut out.
i am little worried that the engine light has come on, do you know what
tools i need to read the engine fault code on this model jimny as i have
read its a obd2 on some websites and on others it says obd2 doesnt work
with there jimnys. and do u have price for the cheapest scanner that would
do the job and also how i could fix the rough idle would be greatly
appreciated thanks



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard