RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Suzuki Jimny 12/1998 1.3L G13BB, ECU 33920-81A5


Member

Status: Offline
Posts: 9
Date:
RE: Suzuki Jimny 12/1998 1.3L G13BB, ECU 33920-81A5
Permalink  
 


Hi All,

Problem solved, my fault, I put 20L of DEISEL in the tank.

All cleaned out and going OK now. Vehicle ran OK for a while, but then "Check Engine" light came on. DTC code 13 (HO2S sensor) using MIL. Thanks to this forum.

Not too concerned, the vehicle has over 330,000Kms on the clock.

Now I am trying to figure out how to undo the electrical coupler/connector. See separate post if you can help.

Again, thanks for the forum and your help.

Cheers...Bob

 



__________________


Member

Status: Offline
Posts: 9
Date:
Permalink  
 

Thanks Rhinoman.

Now have a manual, thanks.

I have spark at all times, confirmed with timing light. My understanding is that the CMP sensor is used to trigger the spark via the ECU.

Thanks to your great forum site, I now know how to read the MIL codes. I will do this in the next few days. I will make sure I crank a bit longer.

Again, thanks for all your help. Will let you know how I go.

Cheers...Bob

 

 



__________________


Guru

Status: Offline
Posts: 1211
Date:
Permalink  
 

The Jimny service manual can be downloaded here:

http://www.rhinoman.org

Try checking for codes while cranking, you need to crank for around 15 seconds for a Code 41 or Code 42. Have you put a timing light on to see if you are still getting spark?

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 9
Date:
Permalink  
 

Hi All,

I have a late 1998 Jimny 1.3L G13BB, Denso ECU 33920-81A5, P/N 112000-9120. Repair Manual Series SN413V. I am in Australia and the vehicle was sold new in Australia.

The vehicle just failed to start one day. Engine cranks, tries to run then stops. Fuel pump delivers fuel to injector rail OK. Pump stops after about 2 seconds. Spark is OK at all plugs while cranking. CMP sensor (Camshaft) OK, checked by replacement with new unit. I believe this sensor is used to trigger spark, which is OK. The "Check Engine" light comes on with Ignition On, Engine Off (ie Lamp is OK). It did not stay on with Engine Running just prior to this failure. I asked a Suzuki repairer where the CKP Crankshaft sensor is located. He advised there is no CKP sensor on the G13BB in this VIN range.

I do not have access to a scan tool at this stage. I was going to buy an OBD2 Scan Tool, glad I didn't! I have only just discovered how to read the "Check Engine" light on this site and have not done this yet as the vehicle is stranded about 20 miles from home. Will do so in the next few days.

I have a soft copy of the SN413 Repair manual, but this is for the M14 DOHC engine, not the G13BB SOHC.

Does anyone know where I can download an SN413V manual as Suzuki Australia has withdrawn all Repair Manuals from sale in Australia?

I know I have spark and fuel until the fuel pump is shut down after about 2 seconds, presumably by the ECU because some sensor is faulty. Can anyone offer any suggestions as to what the problem could be, or what I should check next?

Thanks in anticipation...Bob

 

 

 

 

 

Can anyone offer any suggestions on where to look for this problem.



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard