RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: G10B and G13BB ECU


Guru

Status: Offline
Posts: 1228
Date:
RE: G10B and G13BB ECU
Permalink  
 


Please post pics.



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 9
Date:
Permalink  
 

Would appreciate that... if you need i can post pics of both the ecm boards.

let me know.



__________________


Guru

Status: Offline
Posts: 1228
Date:
Permalink  
 

I've been abroad, I hope to complete some outstanding tasks in the next few days.



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 9
Date:
Permalink  
 

Any updates on this brother!!?



__________________


Guru

Status: Offline
Posts: 1228
Date:
Permalink  
 

Mail received, I'll take a look at it next week thanks.



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 9
Date:
Permalink  
 

I have sent you a mail.



__________________


Member

Status: Offline
Posts: 9
Date:
Permalink  
 

Surely il do that ...



__________________


Guru

Status: Offline
Posts: 1228
Date:
Permalink  
 

Please email me the pictures, on the forum they are too small to read:

 

engineering@rhinopower.org



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 9
Date:
Permalink  
 

Any pointers!!!!!!

 

help



__________________


Member

Status: Offline
Posts: 9
Date:
Permalink  
 

No i havent got rhinoview running as yet,I have to figure out which cable would fit on to it.

Oxygen sensor seems ok as i have no issues in startup when i use the G13BB ecm,Only with G10B ecm the engine chokes until warm up.Advancing or retarding the distributor makes no improvement to the situation.

I think i should replace the O2 sensor!

I am uploading pinouts for both the ecm's as per service manual.

Changing pins would be easier compared to changing the harness,as that would again mean a lot of things to be rewired.

Could you also help me as to what connector i would need to read this ecms?I would like to buy one asap.



Attachments
__________________


Veteran Member

Status: Offline
Posts: 46
Date:
Permalink  
 

speedfly01 wrote:

Location INDIA

G10B ecm has this number 33920M70FB

 

...

However when i start my car on G10B ecm it stutters for afew mins till warm up and then runs ok,whereas with the G13BB ecm it runs fine right from start up.

Is this due to 1300 engine demanding more fuel and igniton ?

...

 Have you got RhinoView running on it yet ?

What ECU numbers do you get from the two ECUs ?

Can you see O2 sender values incase it runs ok unitl it changes to open loop ?



__________________


Member

Status: Offline
Posts: 9
Date:
Permalink  
 

would the pin out help you in this case?i can upload it.Iam new to this and cant figure which pins to move where.

Il upload the pinout could you have a look and suggest?



__________________


Guru

Status: Offline
Posts: 1228
Date:
Permalink  
 

Have you used all the 1.3 sensors? maybe the pin out is slightly different. If the ECUs are Denso then they usually have the pin designations printed on the circuit board. If the ECU functions and sensors are the same then iis possible to swap around the pins in the ECU connectors.



-- Edited by Rhinoman on Monday 11th of June 2012 06:23:13 PM

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 9
Date:
Permalink  
 

Location INDIA

G10B ecm has this number 33920M70FB

I have done a engine swap from G10B to G13BB,unfortunately when i install the G13BB ecm power supply to main relay remains continously on and drains my battery flat in 2hrs.

If i run on my G10B ecm i do not face the same issue so am sure there is no issue with relay wiring being damaged anywhere.

However when i start my car on G10B ecm it stutters for afew mins till warm up and then runs ok,whereas with the G13BB ecm it runs fine right from start up.

Is this due to 1300 engine demanding more fuel and igniton ?

I have to sort this issue and the only way is if i can install the ignition and fuelling of G13BB on G10B ecm?

Or i have to change the entire wiring harness which is a big big pain.

Sugest sumthing !!



__________________


Guru

Status: Offline
Posts: 1228
Date:
Permalink  
 

The only G10B ECUs that I have seen have been quite different from the G13BB Jimny ECUs that I have dealt with before. It would not be possible to swap the chips directly.

Can you be more specific with model and location, thanks.



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 9
Date:
Permalink  
 

Hi everybody!

I would like to know if the G10b and G13BB ecu have the same fuel and ignition?

Although both get the car up and running would there be a difference in both? If so can we remove the chip from G13BB ecu and fix it in the G10b ecu?

thanks in advance..



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard