RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: 33920-70H2 M15A AWD Ignis ( 2002 GM Cruze)


Guru

Status: Offline
Posts: 1228
Date:
RE: 33920-70H2 M15A AWD Ignis ( 2002 GM Cruze)
Permalink  
 


I don't produce the ELM tool or any software for it so I can't support that. I am considering producing a tool that will support SDL/KWP and Suzuki mode on OBD2 ECUs but first I need to get my hands on an SDL/KWP ECU to reverse engineer.

If you are OBD2 then you should be able to get support on the other forums, if not then this is probably the best place to discuss it.

 



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Veteran Member

Status: Offline
Posts: 46
Date:
Permalink  
 

not yet. I'm reading up on if i want to go with a hardware or software for diagnostic and tuning use.

I'm swapping out a blown gearbox first.  Also i assume ELM and its tools is directly related to this site( RV is ) so i'll take the questions to Suzuki-forums, unless your wanting to discuss/ support for other than SDL in these threads ?



__________________


Guru

Status: Offline
Posts: 1228
Date:
Permalink  
 

Have you tried an ELM tool yet? if the ECU is not OBD2 then the ELM tool won't be able to get any data from it, it can only be used to check that the protocol is a KWP protocol.



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Veteran Member

Status: Offline
Posts: 46
Date:
Permalink  
 

am i losing my touch or is there no diagnostic CEL/MIL test link header on the ignis/Cruze ?

Do we HAVE to use a ELM tool just to get a fault code or is there a link or resistor terminal link on the Balino or all other GM cars i have owned ?

 

 



-- Edited by zukjeff on Tuesday 10th of April 2012 07:39:25 AM

__________________


Veteran Member

Status: Offline
Posts: 46
Date:
Permalink  
 

DENSO.

2E
M15A MT/AT E24
33920-70H2(0)
070H2
112200-3142
12V DENSO
*2231421E*



__________________


Guru

Status: Offline
Posts: 1228
Date:
Permalink  
 

What make is the ECU?



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Guru

Status: Offline
Posts: 1228
Date:
Permalink  
 

Thats an immobiliser-ECU data transfer. If it doesn't connect with an OBD2 tool then its most likely to be SDL/KWP which is a Suzuki proprietary protocol using the ISO9141 physical layer. You can test for it using an ELM tool, have a look in the Maruti/India threads for details.

I haven't yet been able to source an ECU with this protocol, it wasn't used in the EU or in the US where OBD2 was mandated but it has turned up in Aus, India and the Middle East.

 



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Veteran Member

Status: Offline
Posts: 46
Date:
Permalink  
 

ok.. the interface works on the SDL pin  at 7812. 8,N,1.

RV and none of the init codes i have tried work , but i get comms from Termite when i turn the Ign key on. 

19 08 80 5e 32 01 c0 0e
19 04 01 e2
18 08 80 0c 28 07 01 24
18 04 01 e3

looks like KWP

thats a good start. No i have not disabled the airbags and other boxes that may be on the bus



-- Edited by zukjeff on Saturday 7th of April 2012 01:40:37 PM



-- Edited by zukjeff on Saturday 7th of April 2012 02:28:17 PM

__________________


Veteran Member

Status: Offline
Posts: 46
Date:
Permalink  
 

Having troubles getting any good data on this ECM..  has anyone got a GM suzuki to worth ?

connector has pins 4(gnd), 5(gnd), 7(K-line),16(+12),9(SDL)

 

 



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard