RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: 33920-71EN0 - X-90


Guru

Status: Offline
Posts: 1186
Date:
33920-71EN0 - X-90
Permalink  
 


The pin out should be in this document:

www.rhinoman.org/manuals/vitara/99501_60G10.pdf



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Newbie

Status: Offline
Posts: 1
Date:
Permalink  
 

please i need pin out of ecu 33920-eno-x 90 if any one have it

__________________
migosi


Member

Status: Offline
Posts: 16
Date:
Permalink  
 

Well it appears that these looms came standard with the OBD2 style connector.

I'll source one of those in an effort to keep things as standard as possible!

__________________


Member

Status: Offline
Posts: 16
Date:
Permalink  
 

Rhinoman wrote:

The 8V and 16V Vits that I've looked at have been violet/white as well. I would have thoughyt that the X90 would have a J1962 (OBD2 style) connector.




I'm not sure what connector this one came with as I bought the engine, loom & ECU and fitted to my vehicle. The engine had been fitted to another vehicle previously and the wiring loom was a little butchered from that. Hence my loom has no connector at all. I'll be going with your suggestion and sourcing a OBD2 style connector.



__________________


Guru

Status: Offline
Posts: 1186
Date:
Permalink  
 

The 8V and 16V Vits that I've looked at have been violet/white as well. I would have thoughyt that the X90 would have a J1962 (OBD2 style) connector.

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 16
Date:
Permalink  
 

Here are some pics of my X-90 engine's ECU

27122009229.jpg

27122009232.jpg

27122009236.jpg

27122009238.jpg

27122009239.jpg

I need to pull the loom from the vehicle again and trace some wires. I have a couple floating around in there that are connected to nothing, I suspect the "M" wire is one of those.

I just read another post on there (though it refers to a Swift GTi) and it mentioned violet with white trace for the "M" wire. I am sure that I saw one that colour, perhaps the colour convention is consistant between some models?

More once I get the loom pulled out!!!

cheers,

Damo.

__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard