RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Hi from Sweden


Member

Status: Offline
Posts: 5
Date:
RE: Hi from Sweden
Permalink  
 


Yes - fuses are OK inside the car - the one board I could see at least. And yes I found the diagram too for grounds.
In the engine bay though - the 80A fuse was gone or he had broken it somehow (I think thats what he said) and put a wire in. I took a picture of the bey and the ECU.


20181110_155948.jpg



Attachments
__________________


Guru

Status: Offline
Posts: 1197
Date:
Permalink  
 

The earthing points should be shown in the FSM, maybe in the wiring section. Have you checked the fuses? the mileage counter should show, its not directly driven by the ECU.



-- Edited by TechSupport on Sunday 11th of November 2018 12:10:03 PM

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 5
Date:
Permalink  
 

Now I´ve been to see the car and the owner =)

Its not four pin fault diagnostic connector - its 6 pins slot - but only four pins are present. 

Its like the car does not find the engine. No engine light, no milage counter (its blank) and no reaction to the tachometer when cranking the car. 

The engine came from a "Suzuki Wagon" thats all we know. Im trying to find out more but the car from the authorities and doner car has been scrapped. The owner bought the car and the doner engine together from the guy before who didnt have time to make the swap.

So - the original engine had no crank sensor - the donor engine had crank sensor. So the owner took the cam sensor plate from the old engine but kept the doner cam sensor. We put the original sensor bak. No start.

He has also a problem with the lambda sensor. The original lambda sensor is missplaced by the previous owner and the doner engines lambda sensor wires are too short. So thats not connected - but surely it should not matter.

I was thinking of the ground points - but if non of the electrics have been tutched - no grounds should have been taken off? Its always a bit difficult though if one person starts the job (taking out the old engine and buying the new engine) and an other person does the rest.

And - we had a look inside the ECU - I  dint have any magnifying glas - but it all did look very good. Both sides. 
Next, we should find out that the ECU gets power and ground right? Do you know where it is grounded?

Thanks ever so much!!



__________________


Member

Status: Offline
Posts: 5
Date:
Permalink  
 

Should not the engine light still be lit? 
One of the pins in the diagnostic terminal has 8V - Ill go and see the car tomorrow. 
The Jimny service book in the link (Thank you!!) had the 6 pin diagnostic terminal - this car has 4 pins. I have found your page for how to check the codes. But - as said, no Check engine light is present.
Thanks ever so much dear!



__________________


Guru

Status: Offline
Posts: 1197
Date:
Permalink  
 

Workshop manuals can be downloaded from http://www. Rhinoman.org. the usual problem with those swaps is not having the same cam sensor arrangement.

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 5
Date:
Permalink  
 

My hubby and I dont longor have any Suzuki but we had a nice visitor today - and I love finding solutions.
He has bought a Suzuki Jimny 1999, engine code G13BB, that had engine failure. And together it an engine came from Wagon - a later year model.
He has put them together and now the engine wont fire up. The start motor does run. There are no milage numbers coming up either. 
No OBD2 port either - only a OBD1 connector above the glove box. 
I havent seen the car yet. Just heard of it and started to look around if I could find a workshop manual for it. So far I have workshop manuals for Wagon R, Liana, SX4, Swift - but not for Jimny and G13BB engine. 
Any help here guys?
Those TECH1 are not easy to find.... I only have TECH2 (SAAB, Opel and Suzuki).



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard