RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Power loss at WOT


Guru

Status: Offline
Posts: 1197
Date:
Power loss at WOT
Permalink  
 


This was a Geo Metro that was suffering from a stumble/power loss at Wide Open Throttle (WOT), this was a repeatable condition that occurred on a short 800ft hill climb. The ECU data was logged using an SDL Interface and TunerPro. After the test drive the log file was played back through TunerPro with a monitor set up to check o2 sensor voltage against load.

On the freeway when accelerating to overtake or at any TPS opening over 37% the O2 sensor voltage went to 900mV with injector pulsewidth going to 4.2ms or higher, indicating fuel enrichments were being applied as expected. This can be seen in the monitor screen capture below:

Geo Metro Tuner Pro data log

 

When the hill climb occurred the log looked quite different:

geo metro fuel bad fuel filter

 

On the climb, the throttle is at WOT although it only indicates around 80% (thick carpet maybe?). RPM is around 3300 RPM so not far from max. torque with speed at 55mph. MAP is showing 930mBar so its under a high load but the O2 sensor voltage has dropped to 38mV indicating a very lean condition when the ECU should be applying fuel enrichments and the O2 sensor should be around 900mV.

Lean under load indicates a fuel supply problem and in this case a replacement fuel filter cured the problem.



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.

Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard