RhinoPower Ltd

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Fuel Trims on 1902 ECU


Guru

Status: Offline
Posts: 1190
Date:
Fuel Trims on 1902 ECU
Permalink  
 


You have to interrogate the diagnostic link.

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Newbie

Status: Offline
Posts: 2
Date:
Permalink  
 

how you find NODE_id of ECU

__________________


Member

Status: Offline
Posts: 15
Date:
Permalink  
 

My ECu is 33920-65DD4, 1902ID,  GV with Auto/Trans.

Just in case could be useful, in Raw word #40 I saw these values for selection lever positions:

P 4
R 8
N 16
D 32
2 64
L 128

At Raw word #42 (normal value zero)

Overdrive switch On = 4
Brake pedal press= 1
Overdrive sw + Brake pedal = 5

 

 



__________________


Guru

Status: Offline
Posts: 1190
Date:
Permalink  
 

I'll check the definition again, there is a version that has no emissions equipment.

__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 15
Date:
Permalink  
 

Thank you for your fast reply,
That seems not to be the problem

First I tested with RV 0.6, 1.1 and 1.2 , only RV 0.6 gave me the floating point error, 

I changed Windows to English USA settings, now no more floating point error in 0.6,

but always not showing the trims values in all versions.

I saw always value zero in word #9,

from begining value 150 in Raw format for word #10,

and after some time running, value 9 for #11.

This seems to be coherent, but never displayed the values in main window or Format data in the Data Viewer..

Maybe is different logic in cars with/ without O2 sensor?

Cheers



__________________


Guru

Status: Offline
Posts: 1190
Date:
Permalink  
 

That may be problem with the way that Windows handles the decimal point, please see this thread:

rhinopower.activeboard.com/t38096087/floating-point-errors/



__________________

1984 Suzuki SJ413K pick up, 1.6 16V Baleno engine
2000 Suzuki Vitara 1.6 8V, many mods
2004 Suzuki Ignis 1.5VVT 4Grip
2006 Suzuki Jimny 1.3VVT JLX+
and many more.



Member

Status: Offline
Posts: 15
Date:
Permalink  
 

Hi everybody
My ECU is a 1902 ID, the J20 motor of my GV2000 has Oxigen sensor at the tailpipe manifold..

In the main screen of RV these two parameters are without value, even zero: TFT, LTFT

In the parameters view the STFT, LTFT and TFT are Zero, but not in the format screen..

Images attached..

Something can be done to read the values?

Thank you..



Attachments
__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard